Bug 1089 - vznetaddbr bug
vznetaddbr bug
Status: CLOSED FIXED
Product: OpenVZ
Classification: Unclassified
Component: vzctl
unspecified
Other Other
: P2 major
Assigned To: Igor Sukhih
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 08:23 EST by Dietmar Maurer
Modified: 2015-04-01 14:46 EDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dietmar Maurer 2008-11-24 08:23:21 EST
The update indroduced a bug:

http://git.openvz.org/?p=vzctl;a=commit;h=93ef4d978a8c609cc04c53f39bc4fe674a089811

seems that:

  ip addr add 0 dev "$host_ifname"

does not create the interface. Instead the old way

 ifconfig "$host_ifname" 0

works.
Comment 1 Dmitry V. Levin 2008-11-24 10:40:06 EST
vzctl creates this device via veth_ctl() function,
so why should vznetaddbr bother?
Comment 2 Dietmar Maurer 2008-11-25 02:50:45 EST
It does not work here (debian etch) - dont know why. 

Anyways, why did you change it - the previous version also use 'ifconfig'?

- Dietmar
Comment 3 Thorsten Schifferdecker 2009-01-22 15:13:14 EST
(In reply to comment #2)
> It does not work here (debian etch) - dont know why. 

Which debian version is used ?
Comment 4 Dietmar Maurer 2009-01-22 15:50:13 EST
debian etch
Comment 5 Thorsten Schifferdecker 2009-01-22 15:59:52 EST
(In reply to comment #4)
> debian etch

used packages:

vzctl (3.0.11-14), Mon, 10 Mar 2008 18:58:04 +0100
iproute (20061002-3), Thu, 14 Dec 2006 20:11:55 +0100

and the OpenVZ kernel is the pve 2.6.24-1 (ovz005) ?
Comment 6 Dietmar Maurer 2009-01-23 02:30:24 EST
I am on Proxmox VE - latest ubuntu kernel and latest vzctl from git.

Anyways, I cant reproduce the error anymore - it works both ways.

But with the new way the interface shows up in " /proc/net/dev", but
not in the output by "ifconfig"? Whats the difference?
Comment 7 Dietmar Maurer 2009-01-26 04:48:39 EST
OK, it does not work a plain Proxmox VE installation:

vzctl 3.0.23
iproute 20061002-3

But it works when I install shorewall - maybe it is dependend in the modules loaded. I will do more tests here.
Comment 8 Dietmar Maurer 2009-01-26 05:13:38 EST
Unfortunately I am unable to see why it works/sometimes. The only consistent difference I see is that the interface shows up in " /proc/net/dev", but
not in the output by "ifconfig".
Comment 9 Dmitry V. Levin 2009-04-09 21:35:47 EDT
Please pull the fix: http://git.altlinux.org/people/ldv/packages/?p=vzctl.git;h=maint
(git://git.altlinux.org/people/ldv/packages/vzctl refs/heads/maint)
Comment 10 Kir Kolyshkin 2009-04-17 12:15:12 EDT
done
http://git.openvz.org/?p=vzctl;a=commit;h=77631ba5589b4bb29cbfd97f4eb35c35446b58a7

fixed in git, will appear in vzctl >= 3.0.24.
Comment 11 Sergey Bronnikov 2015-04-01 14:46:12 EDT
Bug was fixed more than one year ago and there were no complains from reporter after fix. We believe bug fix helped and mark bug as closed.