Bug 824 - IPv6 down with debian lenny as VE
IPv6 down with debian lenny as VE
Status: CLOSED FIXED
Product: OpenVZ
Classification: Unclassified
Component: vzctl
zzz-rhel5-2.6.18_028stabXXX
x86_64 (AMD64) Debian
: P2 normal
Assigned To: Kir Kolyshkin
: 1288 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 10:37 EST by mathgl
Modified: 2015-03-17 04:24 EDT (History)
5 users (show)

See Also:


Attachments
my patch (380 bytes, patch)
2008-03-15 16:35 EDT, mathgl
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mathgl 2008-02-24 10:37:07 EST
I use a prefix like 2002:xxxx:xxxx:22:: and each VE receives an address by this rule 2002:xxxx:xxxx:22:<VEID>::1.

 Since an upgrade in debian lenny. Ipv6 ip configuration look like break.
I try to setup ipv6 with my outdated lenny template, it's working very well. But after upgrade and restart the ve, the problem come back.

 To get ipv6 service back on lenny i just add /0 for the ifconfig command in the debian script. See patch attached.

( kernel version : 2.6.18-028stab053 | vzctl version : vzctl version 3.0.22 )

Mathieu
Comment 1 Kirill Korotaev 2008-03-14 09:56:36 EDT
Mathieu, have you forgot to attach the patch?
Comment 2 mathgl 2008-03-15 16:35:20 EDT
Created attachment 588 [details]
my patch
Comment 3 mathgl 2008-03-15 16:37:12 EDT
Sorry, i was sure it was be done at the creation of the bug.

Mathieu.
Comment 4 Kir Kolyshkin 2008-11-15 17:43:14 EST
There's a Debian bug for this issue:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505792
Comment 5 Kir Kolyshkin 2008-11-17 13:29:49 EST
Fixed in GIT
http://git.openvz.org/?p=vzctl;a=commit;h=9fe02f4a9a42d8d608c401d2508da01f2a07a13e

Will be available in vzctl >= 3.0.24.
Comment 6 Kir Kolyshkin 2009-10-19 09:15:44 EDT
*** Bug 1288 has been marked as a duplicate of this bug. ***
Comment 7 Sergey Bronnikov 2015-03-17 04:24:20 EDT
Bug was fixed more than one year ago and there were no complains from reporter after fix. We believe bug fix helped and mark bug as closed.