Bug 879 - vzmigrate destroys VE by default
vzmigrate destroys VE by default
Status: CLOSED FIXED
Product: OpenVZ
Classification: Unclassified
Component: vzmigrate
unspecified
x86 (i386) Debian
: P2 critical
Assigned To: Andrey Mirkin
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 02:59 EDT by mogorva
Modified: 2015-04-01 14:42 EDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mogorva 2008-04-30 02:59:52 EDT
In case of migrating from host 'A' to host 'B' and there is no rsync installed on host 'B', vzmigrate doesn't fail but deletes the source VE by default.

Maybe this is because the

remove_area=1

line in vzmigrate script.

There is no wiki and man about this default setting.
Comment 1 Ola Lundqvist 2009-05-14 01:10:51 EDT
We need a method to check that rsync exists on the remote side and then exit in that case before the remove command starts. Removing the local area is not documented in the manpage and should be documented.
Comment 2 Kir Kolyshkin 2010-02-15 11:40:11 EST
This bug is caused by the fact that we lose exit code from rsync due to added crap^W stuff. We have removed that stuff, so rsync fail is handled properly.

Fixed by the following commit:
http://git.openvz.org/?p=vzctl;a=commit;h=b430dfded9698b9132d5bfdb8d41b165f4f322f1

"remove area" is documented in vzmigrate.8 man page:

       -r, --remove-area yes|no
              Whether to remove a container area on source HN for the success-
              fully migrated container.

But its default is not documented. I fixed it by this commit:
http://git.openvz.org/?p=vzctl;a=commit;h=4a870373d9d43a318baff2c9d7c580a2744f1c09


Both fixes will appear in >= vzctl-3.0.24
Comment 3 Sergey Bronnikov 2015-04-01 14:42:38 EDT
Bug was fixed more than one year ago and there were no complains from reporter after fix. We believe bug fix helped and mark bug as closed.